D
D
Dymok2018-05-23 21:57:51
Computer networks
Dymok, 2018-05-23 21:57:51

How to set up a management network on Cisco?

Hello. I'm trying to deal with vlans and routing, but I'm not catching up with something.
There is a simple scheme:
5b05b7ee78e46396083772.jpeg
I'm trying to make it possible to ping the switch from the computer. What I did:
set PC1 address 192.168.10.2, default gateway 192.168.10.1

Switch configuration:
Switch(config)#do sh run
Building configuration...

Current configuration : 1212 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/2
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan20
 ip address 192.168.20.2 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

On the router:
Router(config-subif)#do sh run
Building configuration...

Current configuration : 729 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


Ping from PC1 to the router works, but not to the switch, the switch drops the packet after it goes through the PC1-switch-router-switch chain. What am I doing wrong? Thank you.

Answer the question

In order to leave comments, you need to log in

1 answer(s)
W
Wexter, 2018-05-23
@UnluckySerivelha

Your switch does not have a default route, or a route to the network 192.168.10.0/24

Didn't find what you were looking for?

Ask your question

Ask a Question

731 491 924 answers to any question