E
E
Eugene2016-12-29 18:27:19
Computer networks
Eugene, 2016-12-29 18:27:19

Wifi bridge on mikrotik and netgear. Difficulties, who will help?

Good afternoon!
There is a local network with a wifi access point based on a netgear router. It is required to connect mikrotik to netgear via wifi and connect computers to lan ports.
There is a CPE setting in Mikrotik's quick setup. Connecting to wifi netgear happens without problems.
The settings are as follows:
Configuration - Bridge
Bridge - Automatic
Addresses source - Any
Result: Mikrotik connects to wifi but lan clients do not automatically receive ip addresses from netgear.
What is done wrong?

Answer the question

In order to leave comments, you need to log in

2 answer(s)
L
LAA, 2016-12-29
@GoldGoblin

1. You need to set up a bridge between wlan (wifi) and ethernet ports on your MikroTik router.
2. Other configuration (services dhcp-server, nat, firewall, etc.) must be disabled.
I suggest this:
1. reset to factory settings
2. configure the router:

(удаляем существующие бриджи все)
/interface bridge remove [find where name ~".*"] 

(добавляем бридж)
/interface bridge add name=bridge

(потом 2, 3....)
/interface bridge port add bridge=bridge interface=ether1

/ip dhcp-client remove [find where interface~".*" ]

(добавление dhcp-client-а для бриджового интерфейса)
/ip dhcp-client add interface=bridge disabled=no  

(сброс настроек wifi)
/interface wireless reset-configuration [find where name ~".*"]

(задается собственный security profile для беспроводной сети, клиент)
/interface wireless security-profiles add name=my-client \
 mode=dynamic-keys authentication-types=wpa2-psk \
 wpa2-pre-shared-key=WiFiPassWord

(и дальше настраиваете wifi-интерфейс со своими параметрами)
/interface wireless set 0 disabled=no security-profile=my-client mode=station-bridge ssid=..... 

(удаление всех правил файервола)
/ip firewall filter remove [ find where chain ~".*" ]

I hope I didn't forget anything and that you can do it.
I specifically wrote on the command line. This will be useful further and this knowledge will not be superfluous.
Most likely you didn't succeed, because you have wifi mode=station and you still have firewall/nat/dchp-server enabled.
Good luck!

T
TyzhSysAdmin, 2016-12-29
@POS_troi

If I remember correctly how "quick setup" works in ticks (I only used it once and scored because it does nonsense), then at the moment your radio interface acts as a WAN port and, accordingly, your DHCP (netgear) server is located behind the NAT tick.
Reset the tick to zero, do not accept default settings when you first turn it on, configure everything manually in the interface settings.
Do not forget to bridge all interfaces or, more precisely, assign a master port to interfaces and then bridge with WLAN

Didn't find what you were looking for?

Ask your question

Ask a Question

731 491 924 answers to any question