C
C
Cirick2015-08-25 15:08:52
Computer networks
Cirick, 2015-08-25 15:08:52

Whether it is possible to configure connection of 3 providers on tsiska 3845?

I must say right away that I am a complete zero in ciscos and their configuration)) but the situation is such that “IM” is needed and that's it)))
The situation is as follows.
Cisco 3550 and 3845 are available. Cisco 3550
interfaces with several vlans in the network, vlan 1 - 1.1.1.1/24, vlan 2 - 2.2.2.2/24, vlan 3 - 3.3.3.3/24. Each vlan is a separate company with its own devices.
The interface on the cisco 3550 Gi0 / 24 ip 172.20.0.2 looks at the Cisco 3845 Gi 0/0 ip 172.20.0.1 The
routes are approximately the following (why it will be approximately lower):
ip default-gateway 172.20.0.1
ip route 0.0.0.0 0.0.0.0 172.20. 0.1
on 3845 there was one PPPoE connection, and everyone was happily running for the Internet through one provider.
Now the situation has changed, and each company wants to go through its own PPPoE connection (some want their personal account with the provider, others to access the Internet from a different ip, etc.). That is:
Company 1 - vlan1 network 1.1.1.1/24 - must connect PPPoE 1
Company 2 - vlan2 network 2.2.2.2/24 - must connect PPPoE 2
Company 3 - vlan3 network 3.3.3.3/24 - must connect PPPoE 3
On cisco 3845 Gi 0/1 looks towards the provider
Since the provider will be the same for all and the logins have already been received, I tried to create several PPPoE sessions on one Gi 0/1 interface, it turned out something like this:

interface GigabitEthernet0/1
 description WAN
 no ip address
 duplex auto
 speed auto
 media-type rj45
 pppoe enable group global
 pppoe-client dial-pool-number 1
 pppoe-client dial-pool-number 2
 pppoe-client dial-pool-number 3
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname [email protected]фирма_1
 ppp chap password PassworD
!
interface Dialer2
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 2
 ppp authentication chap callin
 ppp chap hostname [email protected]фирма_2
 ppp chap password PassworD
!
interface Dialer3
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 3
 ppp authentication chap callin
 ppp chap hostname [email protected]фирма_3
 ppp chap password PassworD
!

All connections go through, the provider sees them at home.
But then I don’t understand how to set it up so that when accessing the Internet from addresses 1.1.1.1/24 through Dialer 1, from addresses 2.2.2.2/24 through Dialer 2, from addresses 3.3.3.3 through Dialer 3?
I've searched a lot of forums but haven't found an answer...
And some more information.
1 Admins who rule all this sit very far away and are not willing to meet.
2 I don’t have and won’t have access to the Cisco 3550, so the Admins said :-), they only gave it to the 3845 router. Motivating this by the fact that the 3550 routes are complex and cannot be changed.
Like this)

Answer the question

In order to leave comments, you need to log in

4 answer(s)
R
Rinat Garipov, 2015-08-26
@Cirick

Cirick example of using Policy-based routing:
create an access-list:
access-list 101 permit ip 1.1.1.0 0.0.0.255 any
access-list 102 permit ip 2.2.2.0 0.0.0.255 any
access-list 103 permit ip 3.3.3.0 0.0. 0.255 any
create a route-map:
route-map pbr-inet permit 10
match ip address 101
set interface Dialer1 (or whichever one looks at isp1)
route-map pbr-inet permit 20
match ip address 102
set interface Dialer2
route-map pbr -inet permit 30
match ip address 103
set interface Dialer3
release to the Internet:
ip nat inside source route-map pbr-inet interface Dialer1
ip nat inside source route-map pbr-inet interface Dialer2
ip nat inside source route-map pbr-inet interface
Dialer3 policy-based routing uses the source address for manipulation, you need to apply policy on the internal interface:
interface GigabitEthernet0/0
ip policy route-map pbr-inet

S
sharkirill, 2015-08-25
@sharkirill

You can do it through route-map, you can use vrf.

J
John_Alban, 2015-08-28
@John_Alban

Look towards vrf - the least expensive way in terms of resources. You make 3 vrfs, add a couple of vlan / pppoe interfaces to each of them, plus you write your default routes in each vrf.

T
throughtheether, 2015-08-25
@throughtheether

But then I don’t understand how to set it up so that when accessing the Internet from addresses 1.1.1.1/24 through Dialer 1, from addresses 2.2.2.2/24 through Dialer 2, from addresses 3.3.3.3 through Dialer 3?
Experiment with Policy-based routing on 3845.
on 3550 difficult routes
Does it mean catalyst? Interesting people your admins.

Didn't find what you were looking for?

Ask your question

Ask a Question

731 491 924 answers to any question