Z
Z
Zar7472020-02-28 15:51:56
Cisco
Zar747, 2020-02-28 15:51:56

Understanding ip routing and vlan in cisco how to do it right?

Tell the noob to understand if I understand everything correctly
(catalyst 4500)
there are five VLANs 10 20 30 100 200
in them on one computer:
10.100.10.4
10.100.20.4
10.100.30.4
10.100.100.101
10.100.200.1 - gateway
all cisco in one domain

ip vrf mgmtVrf
!
ip domain-name mydomain.com
!
vtp mode transparent
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-1024 priority 24576
!
vlan 10
 name users
!
vlan 20
 name users_buh
!
vlan 30
 name printers
!
vlan 100
 name server
!
vlan 200
 name internet_server
!
!
interface Vlan1
 no ip address
 shutdown
!

write vlan settings
interface Vlan10
description ----- Users Vlan -----
 ip address 10.100.10.2 255.255.255.0
 ip helper-address 10.100.100.250 (dhcp сервер)
 no ip redirects
 standby 10 ip 10.100.10.1
 standby 10 timers 1 3
 standby 10 priority 110
 standby 10 preempt delay minimum 120
 ip policy route-map Internet_access

all vlans have the same configuration, only their addresses ... well, except for the 200th of course)
interface Vlan200
 description ----- Link to FW -----
 ip address ВНЕШНИЙ_ip 255.255.255.252 secondary
 no ip redirects
 no ip proxy-arp
!


ip route 0.0.0.0 0.0.0.0 10.100.200.1
!
ip access-list extended Internet_access
deny ip 10.100.100.0 0.0.0.255 EXTERNAL_ip 0.0.0.15
permit ip 10.100.10.0 0.0.0.255 any
permit ip 10.100.20.0 0.0.0.255 any
permit ip 10.100.30.0

0.0.0.25
!
interface GigabitEthernet3/24
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree bpduguard enable
!


-----------------------------------------
Now the crux of the matter:
1. I understand correctly that in the given situation all vlan as among themselves do not interact?
2. everyone has internet except for 100 vlans 3.
so that vlans start communicating with each other, we add ip routing or not (I have them talking to each other without it :( )?
could communicate with each other, and 20 could see only 100 vlan and the rest did not

, what am I missing? does not work as it should...

Answer the question

In order to leave comments, you need to log in

Didn't find what you were looking for?

Ask your question

Ask a Question

731 491 924 answers to any question