S
S
SGanabiS2018-11-10 13:24:09
iptables
SGanabiS, 2018-11-10 13:24:09

Torrent traffic bypassing VPN on OpenWrt?

On the router with openwrt-18.06 there is a wireguard and all traffic is wrapped there. Please tell me how to properly configure so that torrents go directly?
There are not many clients and it is possible to register a specific port on them. Attempts to correctly register a redirect in etc/config/firewall were unsuccessful.
wg0 - wireguard interface
wg - firewall zone for wireguard
Here are the configs:

etc/config/firewall
config defaults
  option syn_flood '1'
  option input 'ACCEPT'
  option output 'ACCEPT'
  option forward 'REJECT'
config zone
  option name 'lan'
  option input 'ACCEPT'
  option output 'ACCEPT'
  option forward 'ACCEPT'
  option network 'lan'
config zone
  option name 'wan'
  option input 'REJECT'
  option output 'ACCEPT'
  option forward 'ACCEPT'
  option masq '1'
  option mtu_fix '1'
  option network 'wan wan6'
config rule
  option name 'Allow-DHCP-Renew'
  option src 'wan'
  option proto 'udp'
  option dest_port '68'
  option target 'ACCEPT'
  option family 'ipv4'
config rule
  option name 'Allow-Ping'
  option src 'wan'
  option proto 'icmp'
  option icmp_type 'echo-request'
  option family 'ipv4'
  option target 'ACCEPT'
config rule
  option name 'Allow-IGMP'
  option src 'wan'
  option proto 'igmp'
  option family 'ipv4'
  option target 'ACCEPT'
config rule
  option name 'Allow-DHCPv6'
  option src 'wan'
  option proto 'udp'
  option src_ip 'fc00::/6'
  option dest_ip 'fc00::/6'
  option dest_port '546'
  option family 'ipv6'
  option target 'ACCEPT'
config rule
  option name 'Allow-MLD'
  option src 'wan'
  option proto 'icmp'
  option src_ip 'fe80::/10'
  list icmp_type '130/0'
  list icmp_type '131/0'
  list icmp_type '132/0'
  list icmp_type '143/0'
  option family 'ipv6'
  option target 'ACCEPT'
config rule
  option name 'Allow-ICMPv6-Input'
  option src 'wan'
  option proto 'icmp'
  list icmp_type 'echo-request'
  list icmp_type 'echo-reply'
  list icmp_type 'destination-unreachable'
  list icmp_type 'packet-too-big'
  list icmp_type 'time-exceeded'
  list icmp_type 'bad-header'
  list icmp_type 'unknown-header-type'
  list icmp_type 'router-solicitation'
  list icmp_type 'neighbour-solicitation'
  list icmp_type 'router-advertisement'
  list icmp_type 'neighbour-advertisement'
  option limit '1000/sec'
  option family 'ipv6'
  option target 'ACCEPT'
config rule
  option name 'Allow-ICMPv6-Forward'
  option src 'wan'
  option dest '*'
  option proto 'icmp'
  list icmp_type 'echo-request'
  list icmp_type 'echo-reply'
  list icmp_type 'destination-unreachable'
  list icmp_type 'packet-too-big'
  list icmp_type 'time-exceeded'
  list icmp_type 'bad-header'
  list icmp_type 'unknown-header-type'
  option limit '1000/sec'
  option family 'ipv6'
  option target 'ACCEPT'
config rule
  option name 'Allow-IPSec-ESP'
  option src 'wan'
  option dest 'lan'
  option proto 'esp'
  option target 'ACCEPT'
config rule
  option name 'Allow-ISAKMP'
  option src 'wan'
  option dest 'lan'
  option dest_port '500'
  option proto 'udp'
  option target 'ACCEPT'

config include
  option path '/etc/firewall.user'
config zone
  option name 'wg'
  option output 'ACCEPT'
  option network 'wg0'
  option input 'REJECT'
  option masq '1'
  option mtu_fix '1'
  option forward 'ACCEPT'
config redirect
  option target 'DNAT'
  option src 'wan'
  option dest 'lan'
  option proto 'tcp udp'
  option src_dport '6881'
  option dest_port '6881'
  option name 'torrent'
config rule
  option enabled '1'
  option target 'ACCEPT'
  option src 'wan'
  option dest 'lan'
config forwarding
  option dest 'wg'
  option src 'lan'

Answer the question

In order to leave comments, you need to log in

2 answer(s)
S
SGanabiS, 2018-11-18
@SGanabiS

I think vpn-policy-routing is what you need. Suddenly someone will come in handy. I haven't had time to set it up yet.
upd: helped

D
Diman89, 2018-11-13
@Diman89

You need to somehow mark the traffic you need (by port, as you said) and send it where you need

Didn't find what you were looking for?

Ask your question

Ask a Question

731 491 924 answers to any question