D
D
Danil2016-07-01 17:47:46
Mikrotik
Danil, 2016-07-01 17:47:46

How to set balance on Mikrotik?

How to set up load balancing with two WAN ports if they are both dynamic?
Now this topology:
44ea93ae1e9b421c90baddc1e0db741a.png
I tried it according to the instructions: from https://habrahabr.ru/post/244385/

# Настроим сети провайдеров:
/ip address add address=10.100.1.1/24 interface=ISP1
/ip address add address=10.200.1.1/24 interface=ISP2
# Настроим локальный интерфейс 
/ip address add address=10.1.1.1/24 interface=LAN
# скроем за NAT все что выходит из локальной сети
/ip firewall nat add src-address=10.1.1.0/24 action=masquerade chain=srcnat
#Пометим каждое соединение пришедшее снаружи и адресованное нашему роутеру:
/ip firewall mangle add action=mark-connection chain=input in-interface=ISP1 new-connection-mark=cin_ISP1
/ip firewall mangle add action=mark-connection chain=input in-interface=ISP2 new-connection-mark=cin_ISP2
#что бы отвечать через те же интерфейсы, откуда пришли запросы, поставим соответствующую роутинг-марку на каждое соединение.
/ip firewall mangle add action=mark-routing chain=output connection-mark=cin_ISP1 new-routing-mark=rout_ISP1 passthrough=no
/ip firewall mangle add action=mark-routing chain=output connection-mark=cin_ISP2 new-routing-mark=rout_ISP2 passthrough=no
#добавим default gateway в каждую из промаркированных таблиц маршрутизации:
/ip route add distance=1 gateway=10.100.1.254 routing-mark=rout_ISP1 check-gateway=ping
/ip route add distance=1 gateway=10.200.1.254 routing-mark=rout_ISP2 check-gateway=ping
#промаркируем весь траффик из локальной сети
/ip firewall mangle add src-address=10.1.1.0/24 action=mark-routing chain=prerouting new-routing-mark=mixed
#используем ECMP для балансировки траффика из локальной сети
/ip route add dst-address=0.0.0.0/0 gateway=10.100.1.254,10.200.1.254 routing-mark=mixed

But there are static ports. Tell me how to change the dynamics?

Answer the question

In order to leave comments, you need to log in

2 answer(s)
D
Dmitry Shitskov, 2016-07-01
@Veneomin

If I understand correctly, then we mean dynamic IP on interfaces. Instead of

# Настроим сети провайдеров:
/ip address add address=10.100.1.1/24 interface=ISP1
/ip address add address=10.200.1.1/24 interface=ISP2

you should configure DHCP clients on these interfaces. And instead of IP in gateway, specify the names of the corresponding interfaces.

G
Gregory, 2016-07-03
@Maxlinus

if the provider does not prohibit it, you can specify ip yourself in > PPP > Profiles
and at the Internet connection (pppoe example) select the profile you created in the Profile parameter

Didn't find what you were looking for?

Ask your question

Ask a Question

731 491 924 answers to any question