M
M
me1d2020-04-13 14:22:57
Python
me1d, 2020-04-13 14:22:57

Is the site not working correctly or am I doing something wrong?

Stepic.org has a task:
Given a natural number greater than 999. Using one integer division operation and one operation of taking the remainder of the division, find the digit corresponding to the thousands place in the notation of this number.

Sample Input:

1024
Sample Output:

1
I enter this code:

x=int(input())
if x>999:
    print(x//1000%10)

And it tells me that the answer is wrong.

Answer the question

In order to leave comments, you need to log in

2 answer(s)
S
Sergey Tikhonov, 2020-04-13
@me1d

Well, in general, everything seems to be correct, but what exactly the stepik wants, except by experience, probably cannot be found out.

L
Luke Coworker, 2020-04-13
@luuuuke

so don’t say even for a discount, it’s not clear to me personally, I would like a picture in more detail

Didn't find what you were looking for?

Ask your question

Ask a Question

731 491 924 answers to any question